[ProgClub programming] VM won't boot after salt config

John Elliot V | ProgClub jj5 at progclub.org
Sat Jun 29 23:32:48 AEST 2019


I'm really annoyed, because I've seen this problem before, but can't for
the life of me remember what the fix was.

I have a system which fails to boot, like this:

 https://www.jj5.net/file/2019-06-29-230633/understanding-broken.webm

The last lines printed to the screen, which I think are irrelevant, are:

 [19.957783] async_tx: api initialized (async)
 [20.899732] Btrfs loaded, crc32c=crc32c-intel

Then a little bit later:

 [32.469926] random: crng init done
 [32.470551] random: 7 urandom warning(s) missed due to ratelimiting

But as I mentioned I think those log lines aren't relevant and the
actual problem occurred earlier. I tried going frame by frame through
the recording but didn't spot anything that looked promising.

The really strange thing is if I reboot and choose advanced boot options
and load recovery mode, I am then able to 'resume' and boot normally:

 https://www.jj5.net/file/2019-06-29-230633/understanding-works.webm

I have no idea why going via the recovery mode works when I didn't
actually use it to change anything or run diagnostics or anything, just
processed a bare 'resume' and it worked...

As for the root cause it seems that my salt config is corrupting some
file that is leading to this behaviour. But the salt config makes
hundreds of changes, so doing an audit to try and find which file is
corrupt might take a really long time. But, that's what I'm going to do
next, because I'm not sure what else to do...

Can anyone suggest how I debug this one?

Note: this system is a VirtualBox virtual machine running Ubuntu Server
18.04. It is possible for me to use qemu-nbd to mount the virtual disk
and peep into the file system. I have done this and didn't find anything
interesting in syslog or kern.log. But if anyone would like to see a
particular log file let me know and I can go digging for it...

May the Force be with you,
John Elliot V

-- 
|_|O|_| ProgClub
|_|_|O| Because every programmer needs a good club!
|O|O|O| https://www.progclub.org/
-------------- next part --------------
A non-text attachment was scrubbed...
Name: jj5.vcf
Type: text/x-vcard
Size: 231 bytes
Desc: not available
URL: <http://www.progclub.org/pipermail/programming/attachments/20190629/62633afa/attachment.vcf>


More information about the programming mailing list